Chat

Author Topic: 17xx messes with wavetable data? (PC Engine)  (Read 173 times)

Offline snot sos

  • Newbie
  • Posts: 5
  • Delek FTW
    • Email
17xx messes with wavetable data? (PC Engine)
« on: July 21, 2018, 06:25:07 AM »
So I was trying to make a cover of 6beat.mod and on CHN3 pattern 1 it looks like the 17xx effect messed up the wavetable data, more clearly Wave 0. :(
Is there anyway to get around this? Is this a bug? ???

Offline Wavetable Guy

  • Jr. Member
  • Posts: 57
  • Wavetables are cool!
    • YouTube Channel
    • Email
17xx messes with wavetable data? (PC Engine)
« Reply #1 on: July 21, 2018, 09:15:25 PM »
17xx is the effect command that enables/disables PCM playback on the PC Engine. 1701 enables it and 1700 disables it. When you enable PCM playback on any channel of the HuC6280 (PC Engine's soundchip), it disables the wavetable output.

Offline snot sos

  • Newbie
  • Posts: 5
  • Delek FTW
    • Email
17xx messes with wavetable data? (PC Engine)
« Reply #2 on: July 22, 2018, 05:08:22 AM »
17xx is the effect command that enables/disables PCM playback on the PC Engine. 1701 enables it and 1700 disables it. When you enable PCM playback on any channel of the HuC6280 (PC Engine's soundchip), it disables the wavetable output.
I am aware of that, however, when I enabled and disabled the sample output, the waveform of the bass seemed to change as it sounded different... and it only got more drastic when I tried to enable and disable the sample output several times, as the bass sounded nothing like it was when I started, so I had to use 1001 and then 1000 to reset the wave. :-X

Is this normal behavior? :-[

Offline Wavetable Guy

  • Jr. Member
  • Posts: 57
  • Wavetables are cool!
    • YouTube Channel
    • Email
17xx messes with wavetable data? (PC Engine)
« Reply #3 on: July 23, 2018, 02:58:02 PM »
I see what you mean. I've never encountered this before as I've never made a song that switches between samples and wavetable output. I've covered a song where channel 6 switches between noise and samples sometime last year though. I don't really know if it's a normal behavior of the PCE/TG16 (I don't think it's a problem on the SuperGrafx and CoreGrafx as those consoles use a revision of the HuC6280 that fixes some issues, but I can't confirm that). Perhaps Delek or another user can tell you about it?
« Last Edit: July 23, 2018, 03:07:00 PM by Wavetable Guy »

Offline snot sos

  • Newbie
  • Posts: 5
  • Delek FTW
    • Email
17xx messes with wavetable data? (PC Engine)
« Reply #4 on: July 25, 2018, 03:09:12 AM »
The weird part is that I've done another cover with switches between wavetable and sample output for the bass and it didn't have this issue.
I think I should PM Delek about this, by the way, you aren't the only one who doesn't know whether this is normal or not.

(although samples require Direct D/A trickery to be played on the PC Engine, I don't know if that's just a downside of the usual sample playing method)