Chat

Author Topic: [FIXED] reverse selection bug  (Read 2939 times)

Offline InversePhase

  • Newbie
  • Posts: 30
  • Delek FTW
[FIXED] reverse selection bug
« on: September 06, 2015, 06:39:45 pm »
When I try to copy pattern data, sometimes pressing copy will screw up my selection and then not copy all of the data. I couldn't figure it out at first, but then it finally dawned on me....it's when you select "backwards".

So:
Start a new module.
Enter a bunch of notes in the first two channels (mainly so you can see what's going on).
If you select from the first note in the first channel to the last effect in the second channel, and hit copy, everything is fine.

The bug:
If you select from the last effect in the second channel and drag to the first note in the first channel, and hit copy, the selection block changes and that gets copied.

Hope this is an easy fix!
« Last Edit: October 16, 2015, 04:58:06 pm by Delek »

Offline Delek

  • Sali para ver
  • Administrator
  • Hero Member
  • Posts: 1811
    • Delek's Website
    • Email
reverse selection bug
« Reply #1 on: September 06, 2015, 07:50:17 pm »
Easy fix but hard to discover where this was coming from. Thanks for the detailed report, it is fixed now! I updated the pre-release, you can test it out now.

Offline InversePhase

  • Newbie
  • Posts: 30
  • Delek FTW
reverse selection bug
« Reply #2 on: September 06, 2015, 07:51:58 pm »
Thanks very much! Is there a linux prerelease for 10d yet?

Offline Delek

  • Sali para ver
  • Administrator
  • Hero Member
  • Posts: 1811
    • Delek's Website
    • Email
reverse selection bug
« Reply #3 on: September 06, 2015, 08:08:56 pm »

Offline InversePhase

  • Newbie
  • Posts: 30
  • Delek FTW
reverse selection bug
« Reply #4 on: September 06, 2015, 08:11:01 pm »
oh awesome! I remember you said the prerelease was windows-only, and I hadn't checked that post again yet. glad to see this!

Offline Delek

  • Sali para ver
  • Administrator
  • Hero Member
  • Posts: 1811
    • Delek's Website
    • Email
reverse selection bug
« Reply #5 on: September 06, 2015, 08:23:15 pm »
I actually built it for linux just after you requested it in this thread. :)