Chat

Author Topic: > DefleMask v0.12.0 RELEASED! <  (Read 131736 times)

Offline Delek

  • Salí para ver
  • Administrator
  • Hero Member
  • Posts: 1765
    • Delek's Website
    • Email
Download DefleMask
« Reply #15 on: September 05, 2011, 05:19:49 PM »
Yup uninstalled the old and then installed the new. Before Start up screen im afraid ^^; it wont start, says this program has stopped working and then kaputs, no new startup tune either
On Windows 7 DefleMask start and run pretty well. Strange that under Windows Vista that error pops up. :S

Xenmar

  • Guest
Download DefleMask
« Reply #16 on: September 06, 2011, 02:06:50 AM »
Yeah still no dice ^^; reinstalled it to make sure, oh well i guess vista's just out of luck for now. Still need to say though that when it worked for me i was majorly impressed, you even outdid Shiru in terms of pure sound :)

Offline Demick12

  • Member
  • Posts: 175
  • Sealed for freshness past the expiration date...
    • Email
Download DefleMask
« Reply #17 on: September 06, 2011, 04:31:04 AM »
One question: I noticed in the help doc that the B effect is reserved for Position Jump. Am I correct in assuming it hasn't been added into the tracker yet (seems like it might be implemented...)?
I am not insain, I have just been evilly reprogrammed. -Cyber-Lip

Offline Delek

  • Salí para ver
  • Administrator
  • Hero Member
  • Posts: 1765
    • Delek's Website
    • Email
Download DefleMask
« Reply #18 on: September 06, 2011, 12:45:58 PM »
Yeah still no dice ^^; reinstalled it to make sure, oh well i guess vista's just out of luck for now. Still need to say though that when it worked for me i was majorly impressed, you even outdid Shiru in terms of pure sound :)
Do you downloaded the 3.7 version?, what version started fine?, 3.5?. I'm trying to figure out why the 3.6 just won't open in Vista, I think that is the new startup screen using Genesis, because that was the unique huge change on the startup screen.

If I make a 3.7 version without startup sound, could you please test it to see if the problem is still there?. Thanks, you can download the 3.7 version without startup sound from HERE.

One question: I noticed in the help doc that the B effect is reserved for Position Jump. Am I correct in assuming it hasn't been added into the tracker yet (seems like it might be implemented...)?
Exactly, will be implemented on next versions using the LOOP offset of VGM files and using LOOP command on MMFs of YMU759.
« Last Edit: September 06, 2011, 01:36:06 PM by Delek »

Offline Demick12

  • Member
  • Posts: 175
  • Sealed for freshness past the expiration date...
    • Email
Download DefleMask
« Reply #19 on: September 06, 2011, 04:13:14 PM »
Do you know if there's an option to play with the highlights and secondary highlights settings i.e. place the highlights every given number of lines instead of just 4, and the secondary highlights the same? That would be mad convenient for 900 BPM music.
I am not insain, I have just been evilly reprogrammed. -Cyber-Lip

Xenmar

  • Guest
Download DefleMask
« Reply #20 on: September 06, 2011, 10:27:35 PM »
So far so good with the no startup sound version. The tracker loaded up perfectly, and the Ym2612 seems to be working 100% fine now with the PSG. PSG and FM are going strong and havent had any glitches yet woot!

Offline Delek

  • Salí para ver
  • Administrator
  • Hero Member
  • Posts: 1765
    • Delek's Website
    • Email
Download DefleMask
« Reply #21 on: September 06, 2011, 11:25:49 PM »
Wow, it is good to know that I finally got what the problem was, however I'm trying to wonder why the startup tune refuses to load on Windows Vista. Strange...

Xenmar

  • Guest
Download DefleMask
« Reply #22 on: September 06, 2011, 11:33:50 PM »
Wish i could help there ^^; im a sprite artist but i cant program stuff, let me know if ya need me to test anything else if ya need

Offline Delek

  • Salí para ver
  • Administrator
  • Hero Member
  • Posts: 1765
    • Delek's Website
    • Email
Download DefleMask
« Reply #23 on: September 06, 2011, 11:40:50 PM »
Wow, thanks a lot!. I'm "cleaning" the startup code to see if I can narrow the core of the problem.
Could you please test THIS version?.

Many thanks!.

Xenmar

  • Guest
Download DefleMask
« Reply #24 on: September 07, 2011, 12:00:18 AM »
Seems to be working minus playback speed :P Its a bit touchy. The editors are working fine on Genesis/ MasterSystem, effects seem to work well, but the playback speed for the pattern editor seems off, sometimes it will go really fast, sometimes slow, sometimes normal speed that you set. Not sure whats going on with that one exactly ^^;

Offline Delek

  • Salí para ver
  • Administrator
  • Hero Member
  • Posts: 1765
    • Delek's Website
    • Email
Download DefleMask
« Reply #25 on: September 07, 2011, 12:05:11 AM »
Could you test THIS ONE?, maybe the startup tune works right. I hope so.

Xenmar

  • Guest
Download DefleMask
« Reply #26 on: September 07, 2011, 12:18:23 AM »
Startup Successful, no noticeable latency on it, and program started up normally  ;D

Offline Delek

  • Salí para ver
  • Administrator
  • Hero Member
  • Posts: 1765
    • Delek's Website
    • Email
Download DefleMask
« Reply #27 on: September 07, 2011, 12:22:33 AM »
:D NIIICE :D

The 3.8 version will be released soon, after some other changes. Thanks Xenmar for your help to solve this problem. :D

Xenmar

  • Guest
Download DefleMask
« Reply #28 on: September 07, 2011, 12:37:25 AM »
Just glad to help with anything i can. Once this tracker gets finalized its going to be something alot of people will want to use and from what ive experienced its alot more intuitive and accurate than the other current Genny trackers around. Not to mention that it incorporates FM synthesis as a whole on the side. :)

Offline kinkinkijkin

  • Newbie
  • Posts: 41
  • Delek FTW
Download DefleMask
« Reply #29 on: September 07, 2011, 03:03:31 AM »
Yup uninstalled the old and then installed the new. Before Start up screen im afraid ^^; it wont start, says this program has stopped working and then kaputs, no new startup tune either
On Windows 7 DefleMask start and run pretty well. Strange that under Windows Vista that error pops up. :S
I got it in 7 64-bit test mode. Not in the newer version...