Chat

Author Topic: > DefleMask v0.12.0 RELEASED! <  (Read 195774 times)

Offline NARFNra

  • Jr. Member
  • Posts: 98
    • Email
> DefleMask 10 pre-release -FEEDBACK, PLEASE- <
« Reply #225 on: February 11, 2015, 03:57:19 am »
For some reason, when using the stereo on the genesis on linux, if I stop playing and then press keys the notes stay mono in one ear or the other. However, some keys will still play in stereo?

Offline Delek

  • Sali para ver
  • Administrator
  • Hero Member
  • Posts: 1810
    • Delek's Website
    • Email
> DefleMask 10 pre-release -FEEDBACK, PLEASE- <
« Reply #226 on: February 11, 2015, 10:23:46 am »
Nice catch. I'ill fix it asap.

Offline DevEd

  • Full Member
  • Posts: 359
  • Not to be confused with Delek
> DefleMask 10 pre-release -FEEDBACK, PLEASE- <
« Reply #227 on: February 11, 2015, 01:55:05 pm »
ANOTHER GAME BOY WAVE CHANNEL BUG, WHY AM I NOT SURPRISED?

For some reason, when the song loops, it works fine in Deflemask, but in the exported GBS, the wave and volume are retained after the song loops, ignoring whatever the volume and wave are supposed to be set to after the loop point.

Example: At start of song, volume is set to F and wave to 0. Before the song loops to the start, the volume is 8 and the wave is 1. Right after the song loops to the start, the volume is 8 and the wave is 1 instead of F and 0 respectively.

Offline Delek

  • Sali para ver
  • Administrator
  • Hero Member
  • Posts: 1810
    • Delek's Website
    • Email
> DefleMask 10 pre-release -FEEDBACK, PLEASE- <
« Reply #228 on: February 11, 2015, 04:23:30 pm »
ANOTHER GAME BOY WAVE CHANNEL BUG, WHY AM I NOT SURPRISED?
Because you are using a pre-release.
For some reason, when the song loops, it works fine in Deflemask, but in the exported GBS, the wave and volume are retained after the song loops, ignoring whatever the volume and wave are supposed to be set to after the loop point.

Example: At start of song, volume is set to F and wave to 0. Before the song loops to the start, the volume is 8 and the wave is 1. Right after the song loops to the start, the volume is 8 and the wave is 1 instead of F and 0 respectively.
I will fix this ASAP.

Offline UltrasonicMadness

  • Jr. Member
  • Posts: 90
    • My Website
> DefleMask 10 pre-release -FEEDBACK, PLEASE- <
« Reply #229 on: February 12, 2015, 07:57:54 am »
New bug (I think): Whenever I load a module, there is always an asterisk displayed at the end of the module location text on the bottom left, even if changes have not been made.

Offline Delek

  • Sali para ver
  • Administrator
  • Hero Member
  • Posts: 1810
    • Delek's Website
    • Email
> DefleMask 10 pre-release -FEEDBACK, PLEASE- <
« Reply #230 on: February 12, 2015, 09:29:00 am »
Nice one!, thanks!

Offline UltrasonicMadness

  • Jr. Member
  • Posts: 90
    • My Website
> DefleMask 10 pre-release -FEEDBACK, PLEASE- <
« Reply #231 on: February 12, 2015, 09:53:57 am »
De nada  :)

Offline SpoonyBard

  • Global Moderator
  • Full Member
  • Posts: 293
  • Music's in my name!
    • Email
> DefleMask 10 pre-release -FEEDBACK, PLEASE- <
« Reply #232 on: February 14, 2015, 12:42:54 am »
I've noticed that sometimes when I play a song, there's a random green block in one of the columns, and sometimes it appears in more than one column. It's nothing huge, but I have a feeling if someone doesn't bring it up no-one else will.
Music truly is without age.

Offline Delek

  • Sali para ver
  • Administrator
  • Hero Member
  • Posts: 1810
    • Delek's Website
    • Email
> DefleMask 10 pre-release -FEEDBACK, PLEASE- <
« Reply #233 on: February 14, 2015, 02:24:08 am »
That's the mouse over color. I should not show that while playing back the song if you are in follow mode. Thanks for reporting.

Offline Delek

  • Sali para ver
  • Administrator
  • Hero Member
  • Posts: 1810
    • Delek's Website
    • Email
> DefleMask 10 pre-release -FEEDBACK, PLEASE- <
« Reply #234 on: February 14, 2015, 11:26:03 am »
Ok so I fixed those 4 bugs:
Game Boy waveform changing now works perfectly, I was not turning the channel off before changing the waveform as explained here: http://www.devrs.com/gb/files/hosted/GBSOUND.txt
Game Boy loop was not re setting all channel default values, it is fixed now. Thanks DevEd.
Unsaved module asterisk ( * ) will not shown anymore on fresh new loaded songs.
The mouse over row color will not be displayed anymore while playing and follow mode activated (it was useless).

Re-download the pre-release from the first post of this thread.

Offline DevEd

  • Full Member
  • Posts: 359
  • Not to be confused with Delek
> DefleMask 10 pre-release -FEEDBACK, PLEASE- <
« Reply #235 on: February 14, 2015, 07:14:59 pm »
Here's a bug related to the Mac version. Opening the application will open a dialog that says "usage: dirname path" instead of launching Deflemask. I have attached a replacement app which fixes this issue.

I am currently using OS X 10.9.4.

appurukid

  • Guest
> DefleMask 10 pre-release -FEEDBACK, PLEASE- <
« Reply #236 on: February 15, 2015, 11:55:33 am »
Two behavioural things about Deflemask I wanted to point out:

1) Pattern Matrix not following to currently selected pattern
Example: I have 20+ patterns. Currently selected pattern is the first of all (CH 00). I can see CH 00 - CH 09 in the matrix. Now, if I navigate to a pattern below CH 09 with ctrl+cursor down, it won't be visible in the matrix, so I won't know which pattern I'm actually in. (CH 00 - CH 09 are still shown in the matrix) If I start playing the song, the matrix will be updated and I can eventually see which pattern I'm in. This is a rather annoying behaviour if you work with lots of pattern imo, the pattern matrix should show which pattern you're working on at all times.

2) When loading samples, browser keeps jumping back to root folder
Example: I make a folder with drums and put it into the sample root folder. Now everytime I load a sample from that folder, the browser will automatically jump back to the sample root, when loading a new sample. It would be more convenient if the browser would just stay in the folder I specified, instead of jumping back to the root.

Offline littlelamp100

  • Member
  • Posts: 108
  • mega drive music is pretty cool
    • Email
> DefleMask 10 pre-release -FEEDBACK, PLEASE- <
« Reply #237 on: February 15, 2015, 07:21:47 pm »
Cutoffs and volume changes aren't working in the GB wave channel in the most recent update yesterday ???
i make music and stuff idk lol

Offline UltrasonicMadness

  • Jr. Member
  • Posts: 90
    • My Website
> DefleMask 10 pre-release -FEEDBACK, PLEASE- <
« Reply #238 on: February 16, 2015, 01:12:42 am »
littlelamp100: I don't understand, OFF and volume changes still seem to work fine in my recent remix.

Delek: Given the frequency of pre-release updates, I think it would be good to add some indication of build date somewhere within DefleMask, whether in the About menu or in the main pattern editor like this.

Offline NARFNra

  • Jr. Member
  • Posts: 98
    • Email
> DefleMask 10 pre-release -FEEDBACK, PLEASE- <
« Reply #239 on: February 20, 2015, 12:48:21 am »
So I've found a weird crash on Linux. I've actually run into this a few times but assumed it was just my crappy computer not being able to handle the memory strain or something and crashing at random. When trying to edit this file, though, I found a way to repeat it. I redid it about 5 or so times without any sort of change, so I recorded it.


Basically, sometimes whenever I try to scroll the pattern matrix DefleMask crashes immediately. Running it in terminal doesn't display much of help: just "Segmentation Fault".

Any idea why this is? Again, I did this five times in a row and it happened every time. Here's the dmf if you want it.
« Last Edit: February 20, 2015, 12:52:43 am by NARFNra »